Issuu on Google+

Práctica 4.- Diseña y Elabora Algoritmos y Pseudocódigos Aldana Apellido Paterno 20137260 No. de Cuenta

Schulte Apellido Materno Nombre(s) 2”B” Grupo No. de Lista

Maithe

11/04/2014 Fecha

Instrucciones: Elabora el Pseudocódigo o algoritmo para: •

Problema 1: Mostrar en pantalla el factorial de cualquier número, introducido desde el teclado..

Inicio Variables N,Fact,aux.

Inicio

Imprimir "Introduce el número: " Leer N aux= n-1. fact=n Hacer fact=fact * aux. Hasta que aux=1 Imprimir "El factorial de ", n, "es:", fact Fin.

Numero

F a c t = 1 C

1


o n t = 1 Fac

t = F a c t x C o n t

Cont = Cont + 1

SI

Cont<=num N Fact

Fin Problema 2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%. • •

Inicio proceso calculo de horas


• • • • • •

escribir “obtener el número de horas que trabajo Leer numhoras • CAL.A Escribir “a cuanto le pagan cada hora” Leer costoxhora Descuento=(numhoras*costoxhora)*.12 Total=(numhoras*costoxhora)-descuento • A=b*x-12%

• • Escribir “El total que recibe el trabajador” 10. Escribir total 11. Fin A

Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: • • •

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.

1.-proceso promedios 2.-Leer b1, b2, b3, b4 3.-Promedio= (b1+b2+b3+b4)/44.-Si promedio>=8 entonces 5.-Imprime promedio 6.-Finsi 7.-Si promedio <8 entonces 8.-Imprimir “Te vas a ordinario (primera vuelta) 9.-Fin si 10.-Leer pv 11.-Si p2=(pv+promedio)/2 12.-Si p2>=6 entonces 13.-Imprimir p2 14.-Fin si


15.-Si p2<6 entonces 16.-Imprimir “Te vas a extraordinario (segunda vuelta) 17.-Finsi 18Leer sv 19.-Pfinal=(sv+promedio)/2 20.-Imprimir “tu calificación final”pfinal 21.-Fin Suma , división , calificaciones ( 1, 2 , 3 , 4 , 5 , 6 , 7, 8 )

Promedio = Division de la suma Promedio =suma de calificaciones ( 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8) Promedio


Practica 4 2 paracial