Issuu on Google+

Version 4.0

BeadCreator Pro 4.0 User’s Guide

Version 4.0

User Guide Version 4.0 03/2008 Product Copyright Š ThoughtFish Media, Inc. This computer program and its documentation are protected by copyright law and international treaties. Unauthorized reproduction or distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the maximum extent possible under the law.

Version 4.0

Introduction..................................................................................................................... 5 Features of BeadCreator Pro ..................................................................................... 5 What’s New in BeadCreator Pro 4.0?........................................................................ 6 Benefits of BeadCreator Pro...................................................................................... 6 System Requirements.................................................................................................... 7 Minimum System Requirements ............................................................................... 7 Recommended System Requirements ..................................................................... 7 Technical Support .......................................................................................................... 8 Installing BeadCreator Pro ............................................................................................ 9 Installing from CD ....................................................................................................... 9 Installing from Net .................................................................................................... 14 Starting BeadCreator Pro ............................................................................................ 14 Setting Permanent Serial Number for BeadCreator Pro........................................... 15 BeadCreator Pro Basics .............................................................................................. 18 Menu System Overview............................................................................................ 20 File Menu ................................................................................................................ 20 Edit Menu ............................................................................................................... 21 View Menu .............................................................................................................. 23 Filters Menu ........................................................................................................... 24 Plug Ins Menu ........................................................................................................ 25 Library Menu .......................................................................................................... 25 Protect Menu.......................................................................................................... 26 Publish Menu ......................................................................................................... 26 Options Menu ........................................................................................................ 26 Upload Menu .......................................................................................................... 27 Help Menu .............................................................................................................. 27 Tool Bar...................................................................................................................... 28 Design Screen Tabs.................................................................................................. 28 Original Tab ........................................................................................................... 28 Bead Pattern Tab................................................................................................... 29 Composite Tab ...................................................................................................... 29 Palette..................................................................................................................... 29 Settings to the Right of BeadCreator Pro Screen.................................................. 30 Set Size of Design ................................................................................................. 30 Bead Effects........................................................................................................... 30 Bead Parameters ................................................................................................... 30 Bead Pattern Image............................................................................................... 31 Create Pattern Button ........................................................................................... 31 Working with BeadCreator Pro 4.0 ............................................................................. 31 How to create a Bead Design? ................................................................................ 31 How to open an image?............................................................................................ 31 How to load the Palette? .......................................................................................... 34 How to specify the size of the design?................................................................... 36 How to specify the density of the design?............................................................. 37 How to set the bead effects for the design? .......................................................... 39 How to set the bead patterns for the design?........................................................ 39

Version 4.0 How to create a customized design?...................................................................... 40 How to edit the colors in a design? ........................................................................ 50 Customizing Existing Colors ............................................................................... 50 Adding Special Effects to Originals and Designs.............................................. 52 Removing Beads from the Design....................................................................... 52 Copying and Pasting Bead Colors ...................................................................... 53 Replacing Colors in the Pattern........................................................................... 54 How to edit a Palette?............................................................................................... 56 Turning Off a Color in the Palette ........................................................................ 56 Editing a Color in the Palette ............................................................................... 58 Limiting the Number of Colors Used................................................................... 59 How to estimate production cost? .......................................................................... 62 Assigning a Price to a Bead ................................................................................. 62 Finding the Total Cost .......................................................................................... 63

Version 4.0

Introduction Welcome! Thank you for purchasing BeadCreator Pro 4.0. BeadCreator Pro is an easy to use software for creating your own customized beautiful bead patterns using any image or from scratch. If you want to create amazing works of bead designs, BeadCreator Pro is a must-have tool. This fantastic program allows you to create an image and have it translated into a "bead map" and shopping list for your project. BeadCreator Pro was designed keeping you in mind, making the fabrication of any bead design fast, easy, simple and profitable! Creating fantastic bead designs had never been so easy! You just have to import your image into BeadCreator Pro, provide some basic information about the type of beads you use and Wow! our software generates the bead design for your image within seconds! When you get everything just right on your screen, you can even print a fullsized preview of your design. This manual helps you to understand BeadCreator Pro and provides you the easy and best ways to work with BeadCreator Pro. The book is intended for users of all levels. You will be able to understand the basics quickly and you will also find that the program is very easy to use. If you have general questions about how to do particular things with the program, please refer to the “Frequently Asked Questions” section of this manual. You’ll find a heap of valuable information there. If you still have questions, don’t worry! We are always there to assist you. Contact our technical support team.

Features of BeadCreator Pro • • • • • •

Import any image and convert it to a bead graph Work from a blank canvas and design your own pattern Zoom factor for different bead configuration Use any size bead, from 1/0 to 22/0, or input your own measurements Create loom, brick, comanche, frill, peyote & 2- to 9-drop peyote bead layouts Choose from exact colour match or gradation colour blends

• •

Change individual bead colours using our floating colour palette Paint, edit, change, modify beads and colours with ease

Version 4.0 • • • • • • • • •

Modify the hue, saturation and brightness from within the program Turn bead colours on and off for more design control Complete control over your finished pattern, including shopping lists, needed beads, full color thumbnails and previews, word patterns, and much more! Print a bead grid or a word pattern Export bead design in a number of graphic formats, including JPG Save settings for working on files later Export pattern, bead list, and design instructions as a PDF file great for beaders who resell patterns Includes all Delica colours, updated as new colours become available Runs on all Windows platforms, including Windows XP.

What’s New in BeadCreator Pro 4.0? • • • •

PaletteCreator – Allows you to easily create custom palettes of your own beads or those of your favorite bead supplier. Pixelator – Allows you to instantly identify RGB, HTML, CMYK, and HSV code for any color anywhere on an image and the same code can be pasted into the PaletteCreator easily. CollageCreator – Allows you to use two or more existing images to create a single merged image that you can open in version 4.0 and convert into a beading design easily. BeadLayers – Allows you to merge two or more existing beading designs into a single design.

Benefits of BeadCreator Pro • • • • • • • • • • • •

Quick and easy installation Greater editing capabilities Supports all image formats Saves your time and effort Greater flexibility of exporting to variety of formats Reduced costs High quality designs Easy to use Interface Faster generating of bead designs Convenient selection and use of any image color Availability on all windows platforms Easily printable bead designs

Version 4.0

System Requirements BeadCreator Pro manipulates image files, which requires a fair amount of “horsepower” from your PC. Make sure your computer meets or exceeds the following requirements.

Minimum System Requirements • • • •

Operating System: Windows 98 (2nd Edition), ME, NT, 2000, XP or 2003 Processor: 500MHz or faster Memory (RAM): 256 MB Hard Drive Size: At least 300 MB of free space

Recommended System Requirements For the best (and fastest) results, we recommend using a computer that meets or exceeds these requirements: • • • • • •

Operating System: Windows 98, 2nd Edition, ME, NT, 2000, XP or 2003 Processor: 1.2GHz or faster Memory (RAM): 512 MB Hard Drive Size: At least 500 MB of free space Graphics Card: SVGA Graphics Card supporting 32-bit color Screen Resolution: 1024 x 768

Note - If your computer system falls somewhere between the minimum and recommended requirements, you should close any other programs while using BeadCreator Pro. This will free up system resources and allow the program to run faster.

Version 4.0

Technical Support Our tech support phone number is 760-870-1729. We have technical support available from 10 am to 4 pm PST. Please make sure to have your serial number handy, and also make sure that you’ve already registered your software at http://www.beadcreator.com/ so that we may assist you more expeditiously. If all of our lines are busy, you’ll be prompted to leave a message and your call will be returned in the order it was received. Using BeadCreator Pro requires that it be activated to enable full use of your software. You’ll need to know a four-digit code that can be found under the Help menu, select Registration. You can either call us to get the activation code, or by selecting the Registration menu choice, it will take you out of the program and to the internet to help you request your permanent serial number. During this time, your software will be fully functional for up to 10 uses. Although we have a great many retailers for this software, please be aware that retailers are not familiar with the intricacies of BeadCreator’s programming. For information, contact our tech support staff. This team represents the people who developed BeadCreator Pro, use it frequently and are your best source for troubleshooting. We also have a BeadCreator User Group where you can join if you own our BeadCreator software. To reach us by mail, our address is PO Box 99, Ramona CA 92065. We have over 13,000 users worldwide using BeadCreator Pro for their designs and we provide free technical support via email and telephone. You can also join our user group that has over 1,000 members and share your ideas and thoughts. Join Now!

Version 4.0

Installing BeadCreator Pro Installing BeadCreator Pro is very easy. Let’s begin! You may have received the program on a CD or downloaded from the Internet. Based on how you received the program, simply follow the steps given below to install BeadCreator Pro.

Installing from CD 1. Insert the CD into your computer’s CD-ROM drive. The set-up program starts automatically. If the set-up program does not start automatically, open My Computer or Windows Explorer in your computer to view the files on the CD.

2. Double-click on the file named Setup.exe.

3. You will see “Welcome to BeadCreator Pro” setup dialog window. Click the Next button.

Version 4.0

4. The license agreement dialog box appears. Read the license agreement, and then click the radio button “Yes” to accept the terms of the preceding License Agreement. Note: You must select “Yes” to finish installing the program.

5. Then Click the Next button to complete the License Agreement.

Version 4.0

6. You will see the User Information dialog box. Enter your Name, Company (if applicable), and Serial # in the fields provided and then click on the Next button.

7. In the Choose Destination screen, specify the destination folder where you want the program to be installed. The default destination folder is C:\Program Files\ BeadCreator Pro. Click the Next button to continue with the installation process.

Version 4.0

8. You are prompted to create a new directory, click the Yes button.

9. When prompted to select the program group, just keep the default group name, BeadCreator Pro. Click the Next button to proceed.

Version 4.0

10. The program will now install itself. When it has finished, the Setup Complete dialog box will appear. Click the Finish button.

11. Now the BeadCreator Pro setup is complete. Click the OK button.

Version 4.0

Installing from Net 1. If you have downloaded BeadCreator Pro from the Internet, you will need to unzip the file you received in order to access the installation files. WinRAR or WinZip is required for you to unzip the files. Once the set-up files are extracted, locate and double-click on the file named Setup.exe.

Note: For the rest of the steps, follow the steps from Step 3 as given under Installing from CD to complete the installation of BreadCreator Pro.

Starting BeadCreator Pro Once the program has been installed, you will be able to launch it by following the simple steps given below. 1. Click on the Windows Start button to select the Programs folder. Select BeadCreator Pro from the list and click the BeadCreator Pro icon.

Version 4.0

Setting Permanent Serial Number for BeadCreator Pro Using BeadCreatorPro 4.0 requires that you activate your copy of your software on your computer. 1. To activate your software, go to the Help menu and choose Registration > Connect for Registration.

2. Make sure that you are connected to the internet. When you select this menu choice, you will be prompted with a “Magic Number� which is a special 4-digit code that provides us the information needed to activate your serial number, and needs to be entered into the website to get your registration code.

Version 4.0

3. Fill in the basic information required as shown below.

4. Enter the Purchase Information of BeadCreator Pro.

5. Enter the information related to your Purchase Decision of BeadCreator Pro.

Version 4.0

6. In the next step, provide details of Gender, Education, hobbies etc.

Version 4.0 Note: You will receive your registration code within 48 hours by email. In the meantime, your software will be functional for a limited time until the registration code is received and entered. 7. To enter the activation code, go to the Help menu and choose Registration > Enter Registration Code.

8. Enter the registration code given by our technical support team in the Registration Code dialog box as shown below and click the OK button. Note: We recommend that you copy and paste the registration code from the email as this prevents transcription errors.

Note: BeadCreator Pro can be installed on only one computer at a time; if you need additional licenses, please contact us for clearance.

BeadCreator Pro Basics When you start BeadCreator Pro, you will be brought to the main design window. This window has menu system and many tools for you to easily generate bead designs. The main design screen of BeadCreator Pro is as given below.

Version 4.0

The Main Design Screen of BeadCreator Pro has an easy to learn and use interface. Its main advantage lies in managing original images and bead patterns simultaneously. You can easily and quickly work on images and edit bead settings. The main design screen has a compact and simple menu system that has all the options required to manage bead designs. The important menus of the interface are File, Edit, View, Filters, Plug Ins, Library, Protect, Publish, Options, Upload, and Help menus.

Below the Menu System, you have the main Tool Bar that has options to edit and manage bead designs, images, and palettes besides printing and exporting options.

Below the tool bar, you have Design Screen Tabs that have four tabs such as Original, Bead Pattern, Composite, and Palette. To the right of the BeadCreator Pro’s main screen you will find the settings that can be altered for specific bead design. The setting options available are Set Size of Design, Bead Effects, Bead Parameters, and Bead Pattern Image.

Version 4.0 We will know in detail about each of these settings and options.

Menu System Overview File Menu

• •

• • • • •

Open Original – Allows you to open an existing source image file for creating your bead design. Scan Original - Has two options o Select Scanner – Allows you to select any TWAIN compliant Scanner to scan an image o Acquire An Image – Allows you to open a scanned image on the screen for applying bead pattern. Save Original As – Allows you to save the changes you made to the original image file as it appears in the Original tab. Open Palette – Allows you to select an existing palette file that specifies the colors available to you for creating the bead design. Save Palette As – Allows you to save the changes you made to the palette file as a separated file. This command is only available from the Palette tab. New – Allows you to create a completely new design from scratch. You must open a palette before this option becomes available. Open – Allows you to open a previously created design from an independent file. Use this to open the design files (*.bc) that have been saved with the Save Design As command. Save – Allows you to save design into a separated file for future use

• •

• • • •

Version 4.0 Save As – Allows you to save your current project as a native BeadCreator file (*.bc). This format retains the program settings and the palette used to create the design. Export - Allows you to export the design in a variety of ways. Available export options are o Export Beaded Image o Export Bead Data o Export into PDF o Export into HTML o Export into DOC Print – Allows you to open the Print dialog box for you to print a hard copy of whatever is currently shown in the active tab of the program. For example, if the Palette tab is open, this command will print the palette. Print Preview - Shows you on the screen what would be printed if you were to select the Print command. Print Setup – Allows you to open the standard Windows Print Setup dialog box where you specify the printer you want to use, paper size and page orientation. You can also configure other printing properties as allowed by your print driver. Exit – Allows you to close the BeadCreator Pro program.

Edit Menu

Copy – Allows you to copy selected features into a different file or into a different area of the same file.

• •

Version 4.0 Paste – Allows you to paste selected features into a different file or into a different area of the same file. Adjust Color o Copy – Allows you to copy tiled image into clipboard o Undo – Allows you to cancel any previous action o Redo – Allows you to apply any canceled previous action o Color Editor – Allows you to edit beads, lines, figures o Design Editor – Allows you to copy a portion of your design and move it onto other areas of the design. o Edit Color Group – Allows you to change the color of all selected beads into a new color. o Use only XX colors – Allows you to Use Only XX Colors dialog box where you can specify the maximum number of colors you want BeadCreator Pro to use in the design. The program will automatically optimize the palette using only that number of colors. o Brush –Provides you with tool to paint the elements of your design such as the beads, lines and figures o Add Text – Allows you to place text elements in the design image. o Use Inventory Colors – Allows you to use bead specific inventory colors or new colors Shaping o Crop Editor – Allows you to crop around the edges of the image, removing them from the image file. o Contour Editor – Allows you to remove blocks of beads within the design image. Note: This is great for doing fringe work. o Design by Sample – Allows you to duplicate the image to create a larger image pattern. o Add/Remove Columns/Rows – Allows you to designate columns or rows to add and remove from the design image. o Change Design/Bead Size – Allows you to modify the base bead size or the size of your design. o Multiple Pattern Formats – Allows you to mix and match the patterns within the same design. Palette o All On – Used in the Palette tab, it instantly turns on all of the colors in the palette. o All Off – Used in the Palette tab, it instantly turns off all of the colors in the palette, except the first color used. Note: Every palette has to have at least one color to exist. o Modify Color – Allows you to change the RGB value of a color in the palette. You must select a color in the Palette tab before you can select this command. o Delete Color – Allows you to remove a color permanently from the palette. o Omit first XX symbols in mfg name – Allows you to replace the manufacturer’s name from in mfg name the column designated as mfg name with a number code.

Version 4.0

View Menu

• • •

• •

Fit image to window – Resizes your image to fit in the window Scale – Allows you to manually adjust the percentage magnification of the image/pattern. Split – Allows you to specify the split point between the image area and the parameters. After selecting this command, a vertical bar will appear across the main BeadCreator Pro window. When you move your mouse, the bar will follow. Click where you want the split point to be. You can also manually click and drag the split point bar to move it. Pattern o Color Map – Allows you to view the location of each color in the design o Clear All Selection – Allows you to clear the selection of all beads o Separate Pattern Preview – Gives you a separate window to preview your design. o Layer Image – Opens Layer View tool bar that you can use to place one design over another to create a layered view. o Outline Bead - Creates an outline around each bead for better definition on the view screen. o Show Grid – Allows you to view your design on the grid. Palette o Palette Columns - Allows you to modify your palette so that designated columns are removed from view. Bars - inserts various bars to the window. Available bars are o Tool Bar - Toggles the tool bar (beneath the menu commands) on and off. o Ruler Bar - Toggles the rulers on and off. The rulers appear along the left and top edges when you are in the Bead Pattern tab. o Status Bar - Toggles the status bar on and off. The status bar appears along the bottom of the program window and shows the dimensions of the pattern, the number of beads, the palette name and other information.

Version 4.0 o Menu Tooltip - Toggles on and off the labels which can be viewed as you move your mouse over each icon. o Pattern Snapshot - Toggles the Pattern Snapshot on and off. Pattern Snapshot gives you quick bead information such as bead’s row, column, color, and summary. When you move your mouse on any bead when you are in Bead Pattern tab, the pattern snapshot of that bead is shown to the left side on the Status bar.

Filters Menu

• • • • •

Mirror – Allows you to make different mirror images of the original image. You can do a left-to-right inversion, a top-to bottom inversion, or both. HSL Effects – Opens the Hue, Saturation and Lightness effects dialog box where you can individually control these three imaging parameters. Rotate 90 degrees – Each time you select this command it rotates the original image clockwise by 90 degrees. Selecting this four times returns the image to its original position. Sharpen – The Sharpen tool gives you the illusion of “focusing” blurry images by increasing the contrast of adjacent pixels. Smooth – The Smooth tool is the opposite of the Sharpen tool. It decreases the contrast between pixels, causing stark color transitions to appear smoother, blended and slightly blurry. Emboss – Embossing can be applied different ways to make a selection appear either “raised” or “stamped” in the surface. It achieves this by converting the image’s color to gray and then tracing the edges with the original fill color. Embossing can be applied at different angles and different orientations to give “light and shadow” illusions to the image, as would occur if you were seeing it from different perspectives. Negative – When you use the Negative tool on an image, the brightness value of each pixel is converted to the inverse value on the 0-255 color values scale. For example, a pixel in a positive image with a value of 255 is changed to 0, and a pixel with a value of 10 is changed to 245. Diffuse - The Diffuse tool makes an image look more blurry by “shuffling the pixels around”. Sharp edges take on a “splatter effect”, as if a painter jabbed at it with the brush instead of painting a smooth line.

Version 4.0 Solarize – The Solarize tool blends a negative and a positive image, which is kind of like blending a color photograph with its black and white equivalent, or exposing a photographic print briefly to light during development.

Plug Ins Menu This menu command file is where you will find smaller subset programs which have been included as complimentary features of the BeadCreator program Pro 4.0 and are used by some artists to further develop their design. For more information on these plugins, visit the www.beadcreator.com website Resource Center.

• • • •

PaletteCreator – Allows you to work on palettes in PaletteCreator CollageCreator – Allows you to manage original image in CollageCreator Pixelator – Allows to view screen pixels in detail and grab the same BeadLayers – Allows you to create complex designs from other designs

Library Menu

• • • • •

New – Allows you to create new design library for storing your designs. Open – Allows you to open an existing design library Edit – Allows you to edit design library Design Files o Browse for Path – Allows you to select path for storing separate BeadCreator Pro design files View Items As o Item Size – Allows you to view your library of stored designs at a designated size.

Version 4.0 o Library Properties – Allows you to set design library properties

Protect Menu

Protection – Allows you to protect patterns by linking them to your serial number

Publish Menu

• • •

• • •

Activate Publishing System – activates publishing system Input Publishing Key – inputs publishing key Choose ISBN o From Library – selects ISBN from library o Purchase ISBN – to purchase ISBN o Assign ISBN – assigns ISBN Print Publication – publishes the design Create Current Pattern Book – creates current pattern book Create Multi Pattern Book – creates multi pattern book in single PDF document

Options Menu

Preferences – Loads BeadCreator Pro preferences dialog box where you Start Up options such as Shortcut Keys, BeadLayers, Memory Usage, Pattern to Auto Saving, and Default Setting for Pattern Print Preview.

• •

Version 4.0 Background Color – Opens the standard Windows Color dialog box from which you can select or create a color. The color you choose becomes the new background color for your current and future designs. Palette Printing Font – Opens the standard Windows Font dialog box from which you can select the font choices for printing palette.

Upload Menu

MyBeadPatterns – Allows you to link to your bead patterns online.

Help Menu

About BeadCreator Pro – Opens the About BeadCreator Pro dialog box which displays version information about the program and license information about the user, including the user’s name, company name and serial number. • Support Center – Links to our technical support team • •

BCP User Group – Links to our BeadCreator Pro’s User Group Registration o Connect for Registration – Connects to our online registration page so that you can get your permanent serial number for activating your software for permanent use Note: If you do not register you will only be able to use this program a few times. o Enter Registration Code – Allows you to enter registration code Backup Center o Sign up for BCP Backups – Allows you to sign up your details for BeadCreator Pro backups o Set Preferences for BCP Backups – Allows you to set preferences for your BeadCreator Pro backups

Version 4.0

Tool Bar Tool

Description To create new design To open original image To open Palette To open Design To save Design To save image as To export image into PDF To print To print preview To undo the previous action To redo the undone action To open Contour Editor dialog box To open Color Editor dialog box To open Design Editor dialog box To view Pattern Preview To open Hue, Saturation, Lightness dialog box To set zooming options in percentage

Design Screen Tabs Design screen tabs allow you to toggle between image, bead pattern, composite design and palette.

Original Tab

Version 4.0 Original tab allows you to manage the original image on the screen.

Bead Pattern Tab

Bead Pattern tab allows you to manage the bead pattern design on the screen.

Composite Tab

Composite tab allows you to manage the composite design.

Palette

Palette tab allows you to manage the palette associated with the design.

Version 4.0

Settings to the Right of BeadCreator Pro Screen Set Size of Design

This window allows you to set the size parameters such as ruler, width, and Height of your design

Bead Effects

This window allows you to set the bead effects such as 3D Round, 3D Circle, 3D Cylinder etc.

Bead Parameters

This window allows you to set the bead parameters such as Bead Size, Width, Height, Spacer Size etc.

Version 4.0

Bead Pattern Image

This window allows you to set the bead pattern image settings such as Color Conversion, Bead Pattern Format, and Comanche grid.

Create Pattern Button

After adjusting the settings for your bead pattern, you can click on the Create Pattern button to create the pattern with your specifications.

Working with BeadCreator Pro 4.0 How to create a Bead Design? The process of creating a bead design is very simple. It has three different easy steps. •

In the first step, you will open a picture, create a new design or scan an image for use in your design.

In the second step, you will select a color palette to let the software know what bead colors you have and you can even customize this palette if necessary. In the third step, you will enter a little bit of information about the overall dimension of the design you want to create and the materials you are using.

After these three steps, BeadCreator Pro will fabricate the pattern with the click of a mouse on button and tells you how many beads are required for your design. A quick click onto the Palette tab shows you how many of each color bead is needed. You can keep changing these settings as necessary until the image has the desired level of clarity. Once you are satisfied with the pattern, save it and take the print out. Now you have everything you need to start beading!

How to open an image? Opening an image file in BeadCreator Pro is easy.

Version 4.0 Helpful Tip! In order to bring a picture into BeadCreator Pro, you must have a digitized version of the picture; that is, you must have an image file that was created from the picture. If all you have is a paper photograph, you can create an image file from it using a scanner. Of course, if you had a scanner you would know that already; so for those if you who have no idea what we are talking about, just know this: You can bring a photograph to most any professional film development or photocopy center, tell them that you want it scanned to an image file and they will be able to do it for you. Provide them with the information below so they will know what type of images you need. BeadCreator Pro can open any of the following types of image files: • • • • • • •

CollageCreator Format GIF (Graphic Interchange Format) JPG (JPEG Format) PNG (Portable Network Graphics Format) PSD (Photoshop Native File) TIF (Tagged Image File Format) BMP (Windows Bitmap)

Helpful Tip! Avoid using high resolution image files, as they tend to hog system resources. We have found that 72 dpi RGB images work just fine. JPG images typically create much smaller files than the other image types and are ideally suited for this type of application. Simply follow the steps given below to open the image file. 1. Make sure the Original tab is selected at the top of the page. Note: This tab always displays the original image.

2. Click on the File menu and select the Open Original option.

Version 4.0 3. The Select Source Image File dialog box displays. Browse to the folder containing the image file you want to import.

4. Select the image file that you want to open and click the Open button. The image

opens in the Original tab of the BeadCreator Pro program.

5. If your image does not fit to the screen (it is either too big or too small), you can resize the image using the magnification tool in the button bar. Just click on this drop-down list and select the desired magnification. To see the entire image as large as possible, select the Fit to Window option.

Version 4.0

Note: Changing the magnification does not affect the design or the original image file at all – it just allows you to view the image larger or smaller.

How to load the Palette? The palette represents the bead colors that are available for you to work with. When you specify a palette, you are telling the software to use only the colors in that palette to create the bead graph. BeadCreator Pro comes with a number of different color palettes preinstalled, plus you can edit and save these palettes under new names or build your own custom palettes. Simply follow the steps given below to load a Palette file. 1. Click on the File menu and select the Open Palette option. The Select A Palette File dialog box displays, showing the directories that contain the available palettes.

2. If you have a custom palette that you want to use, browse to the directory where it is stored. To use the default palettes, browse to the Palettes subdirectory in the BeadCreator Pro folder.

Version 4.0

3. Select the palette file that you want to use, then click on the Open button.

BeadCreator Pro automatically switches to Palette view so you can see the details of the palette you selected.

Version 4.0

Helpful Tip! If you want to try a different palette, you can select a new one simply by repeating the above process. If you like the palette you selected but want to make changes to specific colors, you can do that as well.

How to specify the size of the design? The Set the Size of Design box helps you to set the size of the design. 1. In the Set the Size of Design box to the right side of the main BeadCreator Pro’s screen, specify the measuring units you want to use from the Ruler drop-down list.

2. You can choose inches, centimeters, or millimeters.

Version 4.0

3. In the Width and Height fields, specify the size of the final design that you want to build. When the Proportionate check box is selected, you can specify only one value (Width or Height). The other values are automatically adjusted to retain the proportions of the original image. If you uncheck this box, you can enter both the Width and Height values.

Note: but be aware that the image will be stretched to accommodate the values you enter and will not retain the same proportions as the original.

How to specify the density of the design? The Bead Parameters box to the right side of the main BeadCreator Pro’s screen helps you to set the density of the design. First you must first specify whether you want to work in Inches or Bead units and then enter the appropriate information. 1. If you select Inches, you will specify the size of the beads and the number of beads required will be determined by the program. To proceed this way, choose the Bead Size from the drop-down list and then fine-tune the values in the Width and Height fields as necessary.

Version 4.0

2. If you select Beads, you will specify the number of beads you want to use and the size of the beads will be determined by the program. To proceed this way, use the Width and Height fields to enter the number of beads that you want to use in each row and column.

3. In the Spacer Size field, enter the width of the spacers that will be used between adjacent beads. Helpful Tip! After you enter the bead parameters, you can refer to the Bead Info box to see how many beads are needed (or what size of beads if using Bead units). If you have assigned a cost value to these beads, the estimated cost for the whole design is shown in the Cost field. When you use Inch units, the Count field shows the size of the beads required. When you use Bead units, the Size field shows the number of beads required.

Version 4.0

How to set the bead effects for the design? The Bead Effects box to the right side of the main BeadCreator Pro’s screen helps you to set the bead effects for your design. These effects change the shape of the beads and use different shading to give a sense of depth. Available bead effects are given below.

3-D Round

3-D Circle

3-D Cylinder

Rounded Rectangle

When you select a bead effect, the design is automatically redrawn with the new selection, so you do not have to click on the Create Pattern button again. The Rectangle with Rounded Corners option allows you to change the curvature of the corners by entering a value in the Round Value field. Larger numbers pertain to higher degrees of curvature. The default is 1.

How to set the bead patterns for the design? The Bead Pattern Image box to the right side of the main BeadCreator Pro’s screen helps you to set the bead patterns for your design. 1. In the Color Conversion drop-down list, choose the option you want BeadCreator Pro to use. The available options are as follows.

Color Conversion Option Sharp Color Classic Color Exact Color

Description It causes the program to match the beads to the sharp color of the image. It causes the program to match the beads to the classic color of the image. It causes the program to match the beads to the exact color of the image. As a result, you will see a jagged appearance, especially where straight lines are involved.

Softened Color

Version 4.0 It causes the program to perform color averaging which tends to smooth out straight and curved lines.

2. By default, BeadCreator Pro applies a “loom pattern” design which situates every bead at either 0° or 90° to its nearest neighbor. If you want to try some variations from this, select a different pattern from the Bead Pattern Format drop-down list.

Loom Pattern

Peyote Pattern

2-Peyote Pattern

3-Peyote Pattern

4-Peyote Pattern

5-Peyote Pattern

6-Peyote Pattern

7-Peyote Pattern

8-Peyote Pattern

9-Peyote Pattern

Brick Pattern

Herringbone Pattern

After you select a new format, the bead pattern is automatically redrawn, so you do not button again. You can change patterns as often as have to click the you like to compare the results and see what you like best.

How to create a customized design? BeadCreator Pro allows you to create your own designs from scratch using the currently open palette. Just specify the size of the finished design and the size (or number) of beads and you are ready to start creating your own design! 1. You must open a palette before you can build your own pattern. If you have not done this yet, open the File menu, select Open Palette.

Version 4.0

2. Choose the color palette (*.pal file) that you want to use to build your design.

3. BeadCreator Pro automatically switches to Palette view so you can see the details of the palette you selected.

Version 4.0

4. Open the File menu again and select New.

5. A window appears to designate certain basic information about size, density, background color etc.

Version 4.0

6. In the Request Design Size box, enter the dimensions for the new design you want to create. Note: For more information about these settings, refer, How to set the size of the design?

7. In the Bead Parameters box, specify whether you want to design by Inches or Beads. Make the appropriate selections for the Bead Size, Width, Height, and Spacer Size as appropriate. You may also select a different pattern and even bead effects, if desired. Note: For more information about these settings, refer, How to set the density of the design?

Version 4.0

8. In the Bead Pattern Format box, select the required bead pattern for your design from the drop down list.

Note: For more information about these settings, refer, How to set the bead patterns for the design? 9. In the New Design Color box, click the checkbox of the required color for the background of your design.

10. Similarly, in the Border box, click the checkbox of the required color for the border of your design.

Version 4.0

button. This redraws the blank pattern to the new 11. Click on the dimensions you specified. Note: If there is an image file open in the Original tab, the program may redraw that image by default. If this happens, simply open the File menu and select New again.

Version 4.0 12. Finally, click on the

button to retain the blank pattern on the screen.

13. Now open Edit menu and select Color Editor to access your drawing tools.

14. You will be presented with the Color Editor window as shown below.

Version 4.0 15. From the color palette, select the color that you want to work with.

16. From the Color Editor’s tool bar, choose the appropriate tool for the design you want to draw. In the following example, you will see a blank rectangle is drawn and above it, a filled rectangle is drawn.

Version 4.0

Available tools in Color Editor are given below. •

Pencil Use the Pencil tool on individual beads by clicking on each bead you want to color. You can also use it to create non-linear lines by holding down the primary mouse button and dragging the cursor around. Every bead you drag over will be colored.

Line The Line tool makes it easy to draw perfectly straight lines. Place the cursor at one endpoint of the line and hold down the primary mouse button. Drag the cursor in the direction you want the line to go. You will see a thin black line between the starting point and the cursor which indicates where the line would go if you released the cursor. Move the cursor to the desired endpoint and release the mouse button. A line is drawn between the two endpoints. Note: The Line tool is best used for drawing perfectly straight and diagonal lines however it can be used to draw lines at other angles as well.

Use the Rectangle tool to draw rectangular or square “frames”. Rectangle Place the cursor where you want one corner of the rectangle to be, then holding down the primary mouse button, drag the cursor outward to define the area of the rectangle. A thin black line indicates where the rectangle will be drawn. Move the cursor where you want the opposite corner of the rectangle to be and release the mouse button.

Filled Rectangle This tool functions just like the Rectangle tool above except that the entire area inside the rectangle is filled with the select color. Use this when you want to create a solid colored box instead of a hollow frame.

Version 4.0 •

Ellipse Use the Ellipse tool to draw hollow circles and oval shapes. Place the cursor at an outside edge of where you want the shape to be drawn, then holding down the primary mouse button, drag outwards to define the parameter of the shape. A thin black line indicates the shape and location of where the shape will be created. When the desired shape is attained, release the mouse button.

Filled Ellipse This tool functions just like the Ellipse tool above except that the entire area inside the circle/oval is filled with the selected color. Use this when you want to create a solid colored shape instead of a hollow shape.

Fill Area This tool allows you to fill in any enclosed area with the selected color. It is very handy and can be used in several ways. To use this tool, simply click once on the place where you want to apply it. Filling an enclosed space - If you previously created a rectangular or oval frame, you can select Fill Area tool and click inside the shape to automatically color everything inside the frame. The frame retains its original color. o Re-coloring a solid shape - If you have a solid shape such as a solid oval or rectangle, you can select Fill Area tool and click on the shape to change its color. o Applying the backgrounder color - If you click outside of a closed shape, then every bead that has not already been colored will receive the selected color. o

17. Draw Away! If you make a mistake, use the Undo and Redo buttons to delete and restore your past actions. You can also hit Esc button on your keyboard to cancel the current operation. Helpful Tip! If you only want to view the colors that you have already used in the Color Editor, check the Omit Unused Colors checkbox. This makes it much easier to re-select the colors that you have already used once but does not affect the palette. 18. You can preview your pattern by clicking on the bottom right of this window.

button located on the

19. When you are finished with your design, click the button to close the Color Editor window. The program saves your pattern and displays it in the Bead Pattern tab. 20. Go to File menu and select the Save As option to save your design.

Version 4.0

21. Enter a name for the design in the Save Design As dialog box and click the Save button.

How to edit the colors in a design? Customizing Existing Colors Whether you are working on your own design or using the one imported from an image file, you can edit the colors using the same tools and methods that you use to create new designs. 1. Create/Open the design for which you wish to customize the color. 2. Click the Bead Pattern tab to view the design.

Version 4.0

3. Go to Edit menu and select Color Editor.

4. In the Color Editor Window, select the color you want to add to the design.

Version 4.0

5. From the Color Editor’s tool bar, select the tool that you want to use to apply the color. Note: For more information, refer How to create a customized design? 6. When you are finished making your changes, click the Color Editor window.

button to close the

7. Save the new design.

Adding Special Effects to Originals and Designs Besides being able to change and edit bead colors, BeadCreator Pro can apply more dramatic effects to your designs and/or change your original images. These are accessible through the Filters menu. Note: For more information, refer How to give special effects to a design?

Removing Beads from the Design If desired, you can physically remove a bead from the design, leaving a blank space.

Version 4.0 Note: Deleting a bead is a permanent action and cannot be undone. We recommend that you use the Save As command in the File menu to create a back-up copy of your design before removing beads. 1. Open the design for which you want to remove the bead. 2. Click the Bead Pattern tab to view the design.

3. Right click on the bead you want to remove. 4. Select the Mark Bead option from the pop up window.

5. The bead is now marked for deletion. 6. If you wish to retain the bead, again right click and select Clear All option.

Copying and Pasting Bead Colors 1. Open the design for which you want to copy and paste bead colors. 2. Click the Bead Pattern tab to view the design.

Version 4.0

3. Right click on the bead whose color you want to copy. 4. Select the Copy option from the pop up menu.

Note: You can also select Cut from this menu, but this will completely remove the bead. 5. Right click on the bead to which you want to apply color. 6. Select the Paste option from the pop up menu. The bead now takes the new color.

Replacing Colors in the Pattern If you want to globally replace one color of bead with another throughout your design, you can do that by using the Change Group of Colors dialog box. 1. Open the design for which you want to replace colors. 2. Click the Bead Pattern tab to view the design.

Version 4.0

3. Go to Edit menu and select Edit Color Group.

4. You will be presented with Edit Color Group dialog box.

Version 4.0 5. Right click on the bead for which you want to change the color. This automatically selects the color from the upper color list. 6. Now, from the lower color list, select the new color that you want to replace the current one. 7. Click the button to initiate the change. BeadCreator Pro redraws the pattern with the substitution. 8. You can make similar substitutions for any number of beads. 9. To keep the substitutions, click the click the

button. To restore the original colors,

button.

How to edit a Palette? Turning Off a Color in the Palette If you want to make global changes to the colors in your bead pattern, you can “turn off” specific colors that you do not want the pattern to use. When you turn off a color in the palette, the program removes it from the bead pattern, replaces it with the nearest available color, and refreshes the screen instantly so you can see the results. An alternative to turning off a color is to change it. When you modify a color in the palette, the bead pattern instantly updates itself to reflect the change. 1. Click on the Palette tab (below the menu bar).

2. This shows the colors in the currently active palette. For each color, the Bead Count column shows the number of beads required to create the design, based on the current size and detail settings. Beads with a count of “0” are not used in this design. Note: If you change the bead settings in the right side of the window, the bead count will change instantly to reflect the new settings.

Version 4.0

3. Click on the color that you want to edit. 4. Clear the checkbox in the Use in Pattern column. Note: Clicking on the box again will toggle this option on and off.

5. Click on the Bead Pattern tab.

button to the right side in the BeadCreator Pro’s 6. Click on the screen in order to redraw the design using the modified palette. Note: If you want to restore the color, simply go back to the Palette tab and check the Use in Pattern checkbox. Then recreate the pattern in the Bead Pattern tab.

Version 4.0

Editing a Color in the Palette 1. Click on the Palette tab. This shows you the colors in the currently active palette.

2. Right click on the color that you want to edit and select Modify Color option.

3. You will be presented with Modify Color dialog box.

4. Change the color by modifying the RGB (Red/Green/Blue) values until the desired color is obtained. 5. Click the

button to replace the old palette color with the new one. To

restore the original color, click the

button.

Version 4.0 6. After making the changes to a palette, you should save the palette under a new name so that you can reuse it and still retain the original palette. To do this, go to File menu and select the Save Palette As option.

7. Enter a new file name in the Save Palette As dialog box and click the Save button.

Note: After saving the palette under a new name, you must manually load that palette again to make it active. (File menu > Open Palette).

Limiting the Number of Colors Used BeadCreator Pro has a great feature that lets you limit the number of colors that are used in the palette. For example, if you limit the number of colors to “10�, then the program will automatically interpolate the design and redraw it using only the ten closest colors to the original. 1. Click on the Bead Pattern tab.

Version 4.0

2. Open the Edit menu and select the Use Only XX Colors.

3. You will be presented with the Use Only XX Colors dialog box opens. Enter the number of colors you want to use in the upper right field.

Note: This dialog box shows the Range (the total number of colors in the palette) and the Init. Value (the total number of colors currently used in the design. 4. Click the button to see how the change affects the palette. You should notice that fewer colors are selected in the palette.

Version 4.0 Note: It is easier to use this feature if you sort the palette by Bead Count. This causes the selected colors to always be listed at the top of the column. To do this, click on the word Bead Count at the top of the column until the largest number appears in the first row. 5. Similarly you can repeat the process to further change the number of colors used. When you are ready to redraw the image using only the currently selected colors, click the button. BeadCreator Pro switches to the Bead Pattern tab and refreshes the design. Note: Once you reduce the number of colors, you cannot use this process to go back and increase the number of colors. To learn how to add colors or restore all of the original colors, refer to the next procedure. Restoring the Original Colors Once you have limited the number of colors, you can only increase them by manually adding colors back into the palette. You can do this in different methods. 1. Click on the Palette tab.

2. To enable colors individually, click on the checkbox of each color so that the box is checked.

3. To restore all colors at once, right click on the palette and select All On option.

Version 4.0

Note: You can even go to Edit menu and select All On option. 4. To redraw the image with the selected colors, click on the Bead Pattern tab

5. Click on the screen.

button to the right side in the BeadCreator Pro’s

How to estimate production cost? Another feature of BeadCreator Pro is its ability to assign costs to each type of bead in a particular palette. Once you assign costs, the program can automatically calculate how much it will cost to produce any design based upon the number and type of beads that are used.

Assigning a Price to a Bead 8. Click on the Palette tab. This shows you the colors in the currently active palette.

Version 4.0 9. Right click on the color that you want to edit and select Modify Color option.

10. You will be presented with Modify Color dialog box.

11. Enter the price for this bead using the fields provided. (This would be the cost of a tube of beads, divided by the number of beads in the tube). If the resulting cost were $0.15, you would enter “0” in the Dollar field and “15” in the Cents field. button to assign a price to this bead. When viewed in the 12. Click the Palette tab, the price should now appear in the Price ($) column in this color’s row.

Finding the Total Cost

Version 4.0 In order to accurately estimate the production cost, you need to make sure that you have assigned pricing to all the bead colors used in your design, as described above. Once you have entered the pricing information, BeadCreator Pro will automatically tally the total cost based on the number of beads in the current design and display the results in the Status bar at the bottom of the program window.

Note: If you do not see the Status bar, open the View menu and select Status Bar from the Bars list.


BeadCreatorPro 4